From f625db6f099c55fa933a713e326b1dc55537ba33 Mon Sep 17 00:00:00 2001 From: Martijn Visser <2989614+martijnvisser@users.noreply.github.com> Date: Mon, 26 Oct 2026 20:00:09 +0100 Subject: [PATCH] [FLINK-41226][build] Bump tcnative to 2.0.81 and run CI on Ubuntu 26.04 - Update flink-shaded to 22.0 and netty-tcnative to 2.0.81, matching Flink release-2.4 since FLINK-40527 - Run CI on ubuntu-26.04, since tcnative 2.0.81 needs OpenSSL 3.2+ and ubuntu-24.04 ships 3.0.13 - Install libssl3 instead of the libssl1.0.0 package - Note the OpenSSL 3.2 requirement in the README Co-authored-by: Sergey Nuyanzin Generated-by: Claude Code (Claude Opus 5.5) --- .github/workflows/ci.yml | 7 +++---- README.md | 2 +- pom.xml | 4 ++-- 3 files changed, 6 insertions(+), 7 deletions(-) diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml index 23fea57..3ed675f 100644 --- a/.github/workflows/ci.yml +++ b/.github/workflows/ci.yml @@ -19,7 +19,7 @@ on: [push, pull_request] jobs: build: - runs-on: ubuntu-latest + runs-on: ubuntu-26.04 steps: - uses: actions/checkout@v6 @@ -55,9 +55,8 @@ jobs: - name: Install prerequisites run: | - wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.13_amd64.deb - sudo apt install ./libssl1.0.0_1.0.2n-1ubuntu5.13_amd64.deb - rm libssl1.0.0_1.0.2n-1ubuntu5.13_amd64.deb + sudo apt-get update + sudo apt-get install -y libssl3 libapr1 - name: Compile # https.protocols is a workaround for https://bugs.openjdk.java.net/browse/JDK-8213202 diff --git a/README.md b/README.md index 93e6e32..e08fa88 100644 --- a/README.md +++ b/README.md @@ -94,7 +94,7 @@ For example, we can change the state data dir by putting `benchmark.state.data-d ## Prerequisites The recent addition of OpenSSL-based benchmarks require one of two modes to be active: -- dynamically-linked OpenSSL (default): this uses a dependency with native wrappers that are linked dynamically to your system's libraries. Depending on the installed OpenSSL version and OS, this may fail and you should try the next option: +- dynamically-linked OpenSSL (default): this uses a dependency with native wrappers that are linked dynamically to your system's libraries and needs OpenSSL 3.2 or newer. Depending on the installed OpenSSL version and OS, this may fail and you should try the next option: - statically-linked OpenSSL: this can be activated by `mvn -Dnetty-tcnative.flavor=static` but requires `flink-shaded-netty-tcnative-static` in the version from `pom.xml`. This module is not provided by Apache Flink by default due to licensing issues (see https://issues.apache.org/jira/browse/LEGAL-393) but can be generated from inside a corresponding `flink-shaded` source via: ``` mvn clean install -Pinclude-netty-tcnative-static -pl flink-shaded-netty-tcnative-static diff --git a/pom.xml b/pom.xml index 00b0146..dd8ca87 100644 --- a/pom.xml +++ b/pom.xml @@ -46,8 +46,8 @@ under the License. UTF-8 2.4-SNAPSHOT - 20.0 - 2.0.62.Final + 22.0 + 2.0.81.Final 1.8 2.12 ${java.version}