Repository navigation
Update phpunit/phpunit requirement from ^10.5.32 || ^11.3.3 || ^12.0.9 to ^13.4.5 #406
ci.yml
on: pull_request
cs-stan
/
Coding Standard & Static Analysis
13s
Matrix: testsuite / testsuite-linux
Annotations
13 errors and 7 warnings
|
cs-stan / Coding Standard & Static Analysis
Process completed with exit code 127.
|
|
cs-stan / Coding Standard & Static Analysis
Process completed with exit code 2.
|
|
cs-stan / Coding Standard & Static Analysis
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires phpunit/phpunit ^13.4.5 -> satisfiable by phpunit/phpunit[13.4.5].
- phpunit/phpunit 13.4.5 requires php >=8.4.1 -> your php version (8.2.35) does not satisfy that requirement.
|
|
cs-stan / Coding Standard & Static Analysis
Process completed with exit code 2.
|
|
cs-stan / Coding Standard & Static Analysis
Process completed with exit code 127.
|
|
cs-stan / Coding Standard & Static Analysis
Process completed with exit code 2.
|
|
cs-stan / Coding Standard & Static Analysis
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires phpunit/phpunit ^13.4.5 -> satisfiable by phpunit/phpunit[13.4.5].
- phpunit/phpunit 13.4.5 requires php >=8.4.1 -> your php version (8.2.35) does not satisfy that requirement.
|
|
testsuite / testsuite-linux (8.2, sqlite, lowest, false)
Process completed with exit code 2.
|
|
testsuite / testsuite-linux (8.2, sqlite, lowest, false)
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires phpunit/phpunit ^13.4.5 -> satisfiable by phpunit/phpunit[13.4.5].
- phpunit/phpunit 13.4.5 requires php >=8.4.1 -> your php version (8.2.35) does not satisfy that requirement.
|
|
testsuite / testsuite-linux (8.2, sqlite, highest, false)
Process completed with exit code 2.
|
|
testsuite / testsuite-linux (8.2, sqlite, highest, false)
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires phpunit/phpunit ^13.4.5 -> satisfiable by phpunit/phpunit[13.4.5].
- phpunit/phpunit 13.4.5 requires php >=8.4.1 -> your php version (8.2.35) does not satisfy that requirement.
|
|
testsuite / testsuite-linux (8.2, mysql, highest, false)
Process completed with exit code 2.
|
|
testsuite / testsuite-linux (8.2, mysql, highest, false)
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires phpunit/phpunit ^13.4.5 -> satisfiable by phpunit/phpunit[13.4.5].
- phpunit/phpunit 13.4.5 requires php >=8.4.1 -> your php version (8.2.35) does not satisfy that requirement.
|
|
cs-stan / Coding Standard & Static Analysis
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.2, sqlite, lowest, false)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.2, sqlite, highest, false)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.2, mysql, highest, false)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.6, mysql, highest, false, --ignore-platform-req=php+)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.4, pgsql, highest, false)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|
|
testsuite / testsuite-linux (8.5, sqlite, highest, false)
Node.js 20 is deprecated. The following actions target Node.js 20 but are being forced to run on Node.js 24: actions/cache@0400d5f644dc74513175e3cd8d07132dd4860809, actions/checkout@v4. For more information see: https://github.blog/changelog/2025-09-19-deprecation-of-node-20-on-github-actions-runners/
|