From 4c60687b6bd77658d88643b6b2e696a23a0a6fab Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 10 Sep 2026 11:02:32 +0000 Subject: [PATCH] Update json requirement from ~> 2.7 to >= 2.7, < 4.0 Updates the requirements on [json](https://github.com/ruby/json) to permit the latest version. - [Release notes](https://github.com/ruby/json/releases) - [Changelog](https://github.com/ruby/json/blob/master/CHANGES.md) - [Commits](https://github.com/ruby/json/compare/v2.7.0...v3.0.0) --- updated-dependencies: - dependency-name: json dependency-version: 3.0.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- cf-uaa-lib.gemspec | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/cf-uaa-lib.gemspec b/cf-uaa-lib.gemspec index 8f97ea9..0a196ed 100644 --- a/cf-uaa-lib.gemspec +++ b/cf-uaa-lib.gemspec @@ -32,7 +32,7 @@ Gem::Specification.new do |s| s.require_paths = ['lib'] # dependencies - s.add_dependency 'json', '~>2.7' + s.add_dependency 'json', '>=2.7', '<4.0' s.add_dependency 'mutex_m' s.add_dependency 'base64' s.add_dependency 'logger'